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Foobar2000 configuration for use with the Naim DAC-V1

Foobar2000

Foobar2000 is a freeware audio player for Windows which supports bit perfect
playback of audio files (including high sample rate, 24 bit and DSD files) when
used with an appropriate audio playback device that supports exclusive access
mode. As such it is an ideal application to use with the Naim DAC-V1.

To use Foobar2000 with the Naim DAC-V1 you will need to install Foobar2000
and configure it appropriately. The required procedure and settings are given
in this document. Before you start you will need to download the latest version
of Foobar2000 from www.foobar2000.org.
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Installing Foobar2000

Once you have the Foobar2000 installer executable copied to your computer please run the
installer by double clicking the Foobar2000 installer icon (or right click the icon and select
"Openn).

Configuring Foobar2000

Once Foobar2000 is installed then we need to configure it accordingly for use with the DAC-V1.
Firstly we need to install the WASAPI (Windows Audio Session API) driver - this allows the
Foobar2000 application to bypass the Windows audio mixer and access the audio device directly.
First launch Foobar, if not already launched.

[ foobar2000 Component Installer [—J1
Install the components needed from the
l The following component package will be installed: Foobar website:
L WASAPI
: https:/www.foobar2000.org/compo-
Please centinue OMLY if you trust the web site you obtained this nents/view/foo_out Wasapi
package from. - -

Do you want to continue?

This is an executable file (.exe) and will
install the WASAPI component from the

Yes | [ Mo File:Preferences screen.
LS
Preferences: Components l 7 et
- Components Installed components: Right-dlick a component for additional options.
> Display Mame Version Module
i--Keyboard Shortcuts
” ) Mezi.:f:-brarvor Album List 4.5 foo_albumlist
L. Networking CD Audio Decoder 3.0 foo_cdda
: Playback Converter 1.5 foo_converter
... shell Integration Default User Interface 0.8.5 foo_ui_std
b - Tools Equalizer 1.0 foo_dsp_eq
L. advanced File Operations 221 foo_fileops
foobar2000 core 1.3.3 Core
” "
Online Tagger 0.7 foo_freedb2 Select the Components
ReplayGain Scanner 221 foo_rgscan .
Standard DSP Array 1.3.1 foo_dsp_std e nt I’y n the Ieft h a n d
Standard Input Array 1.0 foo_input_std .
1.7.1 foo_unpack WIndOW and SeleCt the

{unknown) foo_out_wasapi

"Install" button.

Getmore components

Why are some components grayed out? [ Install... ] [gopy report ] [Get updates ]
Reset all Reset page [ Ok ] [ Cancel ] [ Apply ]
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-

foobar2000 preferences

==

Applying these changes requires fookar2000 to be restarted, Continue?

The plugin will be loaded
but at this point it is not
actually installed - to
complete the installation
select the "Apply" button ...
... and "OK" to restart the

ok || Ccancel Foobar2000 application.
L The program will close then
immediately reopen.
<+ foobarz000 1138 )
[File) Edit View Playback Libray Help - [0 [> [ K B [ 0
K Open... Ctil+ 0
G Trackno  Title / track arti Durat...
o e ’ Once Foobar2000 has
pactaer s reopened then once again
R . please select "Preferences"
mm from the "File" dropdown of
ave playlist... rl+
Preferences Ctrl+P the too' bar‘
Exit
Opens the preferences dialog.
rPrEFenaﬂcEs:Cnmpﬁﬂeﬂts l 2 iz--‘
.- Components Right-dick 8 companent for additional options.
- Display Mame ° Version Module
;> ;E;;lln:zr:r::\nrtcuts Album List 4.5 foo_albumlist
Netwnrklngv CD Audio Decoder 3.0 foo_cdda
> Playback Converter 1.5 foo_converter
- Shell Integration Default L.lsel'lmerface 0.9.5 foo_ui_std
; ;DdiI:nced IE;:EOII;:aﬁDns ;gl :Zi:\sepuiq You ShOUId nOW See the
S il P WASAPI output support
i 050 e T e plugin listed in the Installed
Standard Input Array 1.0 foo_input_std . . .
WASEPT outpt support 523 foo out vesan components list. If this is
ZIP[GZIF/RAR Reader 1.7.1 foo_unpack now |isted as above then
we can continue to set
up the remainder of the
required Foobar options.
Get more components
‘Why are some components grayed out? [ Install... ] [gopy rapcrt] [Getmates

Resetall Reset page
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-
Preferences: Cutput

+ Components
Display

- Keyboard Shortcuts
Media Library

- Metworking
Playback

-

i Shell Integration
Tools
- Advanced

Device

[DS : Primary Sound Driver - ]
Null Output
E D5 : Primary Sound Driver
D5 : Speakers (Maim DAC-V1. Audiophilleo.com)
D5 : Realtek Digital Output(Optical) (Realtek High Definition Audio)
D5 : Realtek Digital Output (Realtek High Definition Audio)
WASAPI (event) : Speakers (Realtek High Definition Audia)
VWASAPT (event) : Realtek Digital Ouu Oncal Realtek High Definition Audic

; Spedaks
WASAPI (event) : Realtek Digital Output (Realbek High Deﬁnltlon Audia)
WASAPI (event) : AMD HDMI Output (AMD High Definition Audio Device)
WASAPT (push) : Speakers (Realtek High Definition Audio)
WASAPT (push) : Realtek Digital Qutput{Optical) (Realtek High Definition Audia)
WASAPT (push) : Speakers (Maim DAC-V 1. Audiophileo.com)
WASAPI (push) : Realtek Digital Output (Realtek High Definition Audio)
WASAPI (push) : AMD HDMI Qutput (AMD High Definiton Audio Device)

Fading
Name Fade in Fade out
Pause and stop 100 ms 100 ms
Seck 100 ms 100 ms
Manual track change 100 ms 100 ms
Automatic track change Oms 0ms
Fade in: D
Fade out: D

From the same window,
select the "Playback"
option to expand the
playback options tree - then
choose "Output".

From the “Device”
dropdown list select:
“WASAPI (event) : Speakers
(Naim DACV1.Audiophilleo.
com)”

-
Preferences: Cutput

+ Components

> - Display
-Keyboard Shorteouts
-Media Library

i Metworking
layback

DSP Manager
Output

- Shell Integration
> Tools

i Advanced

Device

[WASAPI {event) : Speakers (Naim DAC-V1. Audiophilea.com) ']

Buffer length

U
1000 ms

Warning: setting too law buffer lenath may cause some wisualization effects to stop working.

Output format
Outputdata format:  [24-bit =] [oither
Refer to your hardware S'bit_ depth above your
P b s N —
32-hit

[ OK. ]’ Cancel ” Apply

... and from the "Output
Format" dropdown list
select "24-bit".

Then click “Apply”.
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Preferences: Advanced

2 |

+~Components
Display

\--Keyboard Shortcuts
-Media Library

Networking

4 -Playback

i -DSP Manager

Qutput

i--Shell Integration
-Tools

. Advanced

WARNMING: Changing any of these settings will most likely result in degraded performance or
compatibility issues, or both, Change them at your own risk.

-Decoding
-Display
-Metworking
4 -Playback
Full file buffering up to (kB) : 0
/| Show error message popups
-Shuffle
verify integrity of played tracks and report errors immediately
Volume step (dB) : 1.0
4 -WASAPT
‘ Hardware buffer in MS - push mode : 200
Hardware buffer in M5 - event mode : 100
i ‘...[¥] High worker process priarity
- Thread priority
..[] Prevent hard disk sleep while playing
-Tagging
-Tools
-Updates

Reset all ||Resetpage ( OK. || Cancel H Apply

Now select the "Advanced"
entry in the left hand
window and open up the
"Playback" options in the
right hand window, then
the "WASAPI" options.
Change the value for the
event mode hardware
buffer from 10 to 100 and
check the "High worker
process priority" checkbox
- these two changes will
help to prevent any glitches
in audio playback caused
by other applications
multitasking. Select "Apply"
and then "OK".

Your installation of Foobar2000 is now configured for use with the Naim DAC-V1.

LISH BitPe

Searching for
test audio._.

message.

Once you have set up your software then you should
test that you are able to drive your DAC “bitperfect” ...
this is done by selecting the “Settings” -> “BitPerfect”
on your DAC-V1, the DAC-V1 will then display this

You should then play the bitperfect test files — please
note that due to the way that Foobar2000 works, it
will be necessary to reconfigure the output format to
16bit or 24bit as necessary to play the 16bit and 24bit
bitperfect test files successfully - as the file begins to
play the DAC-V1 will display this message.
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USH BitPerfect Test
Testing...
727

Mo Errors

LIZH BitPerfect Test
Finished.

Your audio is

BitPerfect

DSD Setup

NAaim

As the audio file progresses, the DAC-V1 will update
the display to indicate how far through the test file it
is, if any errors are found then they will be shown on
this display.

Once the file has completed then you should see the
following.

If you do not then please check your settings are the
same as above and retest.

DSD setup with Foobar is not for the faint of heart! If you plan to use DSD files a lot you may wish

to look at other options such as JRiver.

You need to change the main driver used from the Naim driver to Foobar's DSD custom driver,
then point that to an ASIO4ALL driver, and then point that to the Dac-V1 driver.

There are various setup documents posted on the web such as this one here:
http:/www.audiostream.com/content/how-play-dsd-file-using-foobar2000#ssI TUKJE-

cy6re6MF.97

In addition you also need to install the ASIO driver too.

Foobar2000 configuration
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The setup is as follows:

1. Install the ASIO driver from http:/www.asio4all.com/

2. Install the ASIO Proxy driver from http://sourceforge.net/projects/sacddecoder/files/foo_dsd_
asio/

3. Download the ASIO output plug-in for Foobar2000 from http:/www.foobar2000.org/
components/view/foo_out_asio

Run the installer and it will launch Foobar and install the component. Click apply and Foobar
will restart.

4. Download the SACD Decoder plug-in for Foobar2000 from http://sourceforge.net/projects/
sacddecoder/files/foo_input_sacd/foo_input_sacd-0.8.4.zip/download Open the new zip folder
and double- click ASIOProxylnstall.exe. Follow the onscreen instructions using the default install.

5. Once all drivers and components are installed you need to set up Foobar from
File>Preferences: (Note: File>Preferences and Library>Configure take you to the same place)

1. Select the Output Driver
Playback > Output
Device dropdown > ASIO:foo_dsd_asio
Set buffer to approx 15,000ms.

Preferences: Qutput &I&J

- Components Device
» - Display
. Keyboard Shortcuts [ASIO : foo_dsd_asio v]
- Media Library
- Networking Buffer length
4 Playback
DSP Manager D
| a.Output

15060 ms

Shell Integration
4 - Tools

| i.saoD Output format

i I-Tagging Dither

i Advanced
Qutput data format will be chosen automatically for the selected device.

Reset all ”Resetpage oK ]’ Cancel l’ Apply
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Configure Drivers
Playback > Output >ASIO
Check: 64-bit ASIO drivers

Check: Run with high process priority
Double click the two drivers listed to access driver options.

r

Preferences: ASIO

=)

;- Companents ASIO drivers
> Display
Keyboard Shortcuts ASIO Fireface JRiver Media Center 21
» - Media Library ASIO4ALL v2
- Metvorkng E‘r,:_dssl_adsioc ter 19
iver Media Center

‘ . Pl;-?’g:s(h‘lanager JRiver Media Center 20

4 - Qutput
: [ ASIO 5 . —
Shell Integration Double-dick an entry to activate the driver's control panel.
4. Tools LUse 64-hit ASIO drivers

..... SAC[? Run with high process priority

» - Tagging
‘... Advanced

Custom channel mappings

soundcards.

Reset all Reset page [ OK

This feature allows you to configure alternate channel mappings for your ASIO-enabled

‘fou may need to dose and re-open the foobar 2000 preferences dialog for your newly
added mappings to appear as output devices in the “output” page.

Add New

) [ [

2a.

foo_dsd_asio

Select ASIO4ALL.
Select playback method
DoP Marker.

-

ASIO Proxy 0.8.3

==

ASIO Driver:

ASIO4ALL w2 -

DSD Playback Method: |DoP Marker 0x05/0xFA

DSD to DSD Method: |

PCM to DSD Method: |

DSD/PCM Transition: |

[ Trace to File:

" | Reset |
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2b. ASIO4ALL
select DAC-V1 from device list.
Set buffer sample rate to 2048.

EH  ASIOSALL v2.12 - www.asiodall.cam - feedback@asiodall.com [
WDM Device List
'®  Realtek High Definttion Audio
TR Sl Naim DAC-V. Audiophilleo com

3. Configure Output Mode
Tools > SACD
Output mode — DSD

o
Preferences: SACD l P e

~ Components

> - Digplay

; QOutput Mode: -

i-- Keyboard Shortcuts 3=

> - Media Librar

) i PCM Volume: DSD | Log Overloads

i~ Networking

4 -Playback

; DSP Maniager PCM Samplerate: | 44100

4 -Output

! L. ASIO DSD2PCM Mode: Multistage (Floating-Point) Load Save

i~ Shell Integration
4 -Tools

i -SACD Preferable Area:

ok -Tagging

- Advanced [ ] Editable Tags Store Tags With 150 Linked 2CH/MCH Tags

[ Edited Master Playback
[ Reset all ] [ Reset page ] [ Ok ] [ Cancel ] [ Apply ]

Bitperfect files will still work with DSD set up.

High Res files will not. Set the Driver back to Naim DAC-V1 for these to work.
Go to the Playback > Output > Device dropdown and select DAC-V1.
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